Installation d’un serveur GLPI 0.90.1

Installation d’un serveur GLPI 0.90.1

autres produit banniere

Installation d’un serveur GLPI 0.90.1 (sous Windows et IIS)

Pour un autre de mes projets, j’ai dû mettre en place un serveur GLPI.

dans sa version actuelle, nous parlons de la version 0.90.1
Bien sûr j’ai lu pas mal de site ou blog, et il y a beaucoup d’informations, mais quand on commence à l’installer, il y a plein de petits pièges.

La série sur GLPI

Historique

Mise à jour GLPI

Installation et configuration de Fusion-Inventory dans GLPI

Système de notification sous GLPI

SSO avec GLPI

Utiliser l’active Directory sous GLPI

Installation d’un serveur GLPI 0.90.1

Installation de logiciels grâce à Fusioninventory et GLPI

Montage du serveur Web

Pour le début, j’ai fait la première vidéo sur l’installation de notre serveur.
Si l’on fait des recherche sur internet, On trouve très souvent on voit l’installation sous Linux, mais j’avoue que ce n’est pas ma grande force, donc direction Windows dans sa version 2012 R2. Aussi, on trouve, sous Windows l’installation de GLPI avec un serveur WAMP. Mais Pourquoi installer Apache ou un serveur WAMP,  alors que Microsoft nous fournit son propre serveur web (IIS)?

Celui-ci fonctionne très bien.

Les pré-requis

Donc, direction Microsoft Web Platform Installer 5.0, avec l’installation du FrameWork 3.5 (pour la gestion ….) MySQL et bien sûr PHP.

AttentionAttention, si vous installer la version PHP 5.6, il vous faut le VC+++ 2012
Après, simplement il nous suffit de télécharger notre GLPI, le décompresser et le mettre dans notre serveur IIS.
Ne pas oublier de passer les permissions NTFS, et l’activation de deux composantes filinfo et LDAP dans notre php.ini
Une fois le tout effectué, nous pouvons procéder a l’installation de notre GLPI.

Dans la démonstration, je ne le fais pas, mais je vous conseille fortement de vous créer un compte spécifique dans votre serveur Mysql et de ne pas utiliser l’utilisateur root.

Pour ce faire, je vous conseille de télécharger phpmyadmin qui est simple et efficace.

video_Icon

La vidéo

 

24 thoughts on “Installation d’un serveur GLPI 0.90.1

  1. Tres bonne article. j’ai suivi toute la serie du GLPI sur votre chaine Youtube et j’ai reussi facilement a le mettre en place.
    Merci pour tout votre travail

  2. Bonjour et bravo,
    j’avais trouvé le lien de votre site sur le forum GLPI et je suis vraiment très agréablement surpris de vos tuto. C’est clair et bien expliqué. J’ai fais une machine de test et cela fonctionne parfaitement du coup j’ai suivi la série SSO et notification et pareil cela fonctionne a merveille.
    Je rejoins un de vos lecteur, si vous pouviez faire un tuto pour fusioninventory de la mise en place au déploiement du client et à la remonté d’information ce serait génial.
    Encore bravo pour vos tuto et merci et bonne continuation.

  3. Merci pour tout votre travail. j’ai réussi à mettre en place mon serveur glpi grâce à votre tuto, seulement je sais pas comment accédé à glpi par l’adresse du serveur (192.x.x.x/glpi) au lieu de (localhost) tout court.

  4. Merci pour tout votre travail. j’ai réussi à mettre en place mon serveur glpi grâce à votre tuto, seulement je sais pas comment accédé à glpi par l’adresse du serveur (192.x.x.x/glpi) au lieu de (localhost) tout court.

  5. Je recherche une façon de procéder pour remonter les informations du parc informatique de la société (ordinateurs..) . J’ai installé GLPI version 0.90.5 sur un serveur 2012 r2 et utilisé Fusioninventory cependant les infos ne remonte pas après avoir installé l’agent fusion sur les postes…
    Pouvez vous me dire que puis-je faire pour avoir satisfaction pour mon installation?

  6. Je recherche une façon de procéder pour remonter les informations du parc informatique de la société (ordinateurs..) . J’ai installé GLPI version 0.90.5 sur un serveur 2012 r2 et utilisé Fusioninventory cependant les infos ne remonte pas après avoir installé l’agent fusion sur les postes…
    Pouvez vous me dire que puis-je faire pour avoir satisfaction pour mon installation?

  7. Bonjour Dominique.

    J’ai eu plusieurs demande pour ça, et il va falloir que je fasse une vidéo a ce sujet.
    Mais tout dépend si tu as implanter le SSO et la sécurité.
    Si oui, il faut donner des permissions NTFS sur le sous-répertoire de fusion-inventory.

    Sinon, sur le serveur, il faut paramétrer
    Administration / Entités / Entité racine puis dans l’onglet FusionInventory, ajouter l’URL du service GLPI
    http://mon_serveur

    Bien sur le port doit être ouvert si les firewall sont activés

    Comme je disais, je compte faire prochainement une vidéo. Poiur avoir l’information et etre alerté, le mieux est de s’abonner a ma chaine youtube.

    Cordialement

  8. Bonjour Dominique.

    J’ai eu plusieurs demande pour ça, et il va falloir que je fasse une vidéo a ce sujet.
    Mais tout dépend si tu as implanter le SSO et la sécurité.
    Si oui, il faut donner des permissions NTFS sur le sous-répertoire de fusion-inventory.

    Sinon, sur le serveur, il faut paramétrer
    Administration / Entités / Entité racine puis dans l’onglet FusionInventory, ajouter l’URL du service GLPI
    http://mon_serveur

    Bien sur le port doit être ouvert si les firewall sont activés

    Comme je disais, je compte faire prochainement une vidéo. Poiur avoir l’information et etre alerté, le mieux est de s’abonner a ma chaine youtube.

    Cordialement

  9. Bonjour Francis,
    Merci de votre réponse, pour ce qui est de l’OSS et la sécurité cela ne fait pas partie de ma configuration.
    L’adresse URL a bien été indiquée, pour ce qui est du port ouvert, glpi communique bien pour l’ensemble des PC (envoie de tickets). Peut être un problème de version et ou de configuration de fusion agent!!
    Dans l’attente de votre vidéo si elle pouvait être sur un serveur 2012 r2.
    Cordialement,

  10. Bonjour Francis,
    Merci de votre réponse, pour ce qui est de l’OSS et la sécurité cela ne fait pas partie de ma configuration.
    L’adresse URL a bien été indiquée, pour ce qui est du port ouvert, glpi communique bien pour l’ensemble des PC (envoie de tickets). Peut être un problème de version et ou de configuration de fusion agent!!
    Dans l’attente de votre vidéo si elle pouvait être sur un serveur 2012 r2.
    Cordialement,

Comments are closed.